The speed test tool requires at least version 8 of Flash, which is not supported by your device. Please go to the non-flash broadband speed test survey to manually enter your broadband speed information.